Intermittent Connectivity Issues

Incident Report for FieldEdge

Resolved

The intermittent connectivity issue has been resolved. We will be continuing to monitor performance to ensure stability. Please reach out to FieldEdge support if you are still experiencing system performance issues.
Posted Apr 22, 2025 - 15:13 EDT

Investigating

We are currently investigating reports of general system slowness and difficulty loading lists. We are still investigating the causation of this issue and will post an update once we have identified the causation.
Posted Apr 22, 2025 - 13:00 EDT
This incident affected: Site (Site East, Site West).