Monitoring Integrated Services Impacted by AWS Outage

Incident Report for FieldEdge

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 20:39 EDT

Monitoring

Amazon Web Services (AWS) has been experiencing intermittent global issues for the last 12 hours. FieldEdge's core web and mobile experience is not reliant on AWS but many of our integrated services (Twilio, Sendgrid, Xplor Growth) are reliant on AWS. We are monitoring these services to ensure they are stable and operating until the AWS outage is resolved. If you are experiencing any issues with calls, emails, SMS, or any other FieldEdge services, please reach out to our support team to report the issue.
Posted Oct 20, 2025 - 12:48 EDT
This incident affected: Site (Site East, Site West) and Mobile.