Mobile Login and Logout Delays

Incident Report for FieldEdge

Resolved

This incident has been resolved.
Posted Dec 16, 2025 - 21:19 EST

Monitoring

We are seeing normal behavior in Mobile Login and Logout. We are continuing to monitor the situation with our external vendor to ensure FieldEdge mobile users are not impacted.
Posted Dec 16, 2025 - 11:27 EST

Investigating

FieldEdge is investigating reports of delays when logging in and logging out of the mobile app. We have determined the delay is related to an external service and we are working with this external provider to determine the underlying issue.

Logins and logouts are not failing but they are taking noticeably longer to complete. If your technicians are experiencing delays please advise them to wait for the login or logout to complete.
Posted Dec 15, 2025 - 19:03 EST
This incident affected: Mobile.