Degraded Performance Due to External Vendor Outage

Incident Report for FieldEdge

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 22:36 EDT

Monitoring

FieldEdge services have been restored. The underlying third-party global cloud outage has been resolved and our integrated products have been stabilized. If you are still experiencing degraded performance or unavailable services please reach out to FieldEdge support to report the issue. We will continue to monitor all services to ensure continued availability.
Posted Jun 12, 2025 - 17:36 EDT

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 16:01 EDT

Investigating

FieldEdge is aware of degraded performance across a number of services. These services include our support chat integration, payment processing, PDF generation, and others. These outages are related to a third-party global cloud outage that many of our integrated products rely on. We will continue to investigate this issue and work with the related impacted partners.

If you need to contact support, you can still chat using the following URL: https://xplorcontactcenter.my.site.com/fieldedge/s/
Posted Jun 12, 2025 - 16:01 EDT
This incident affected: Site (Site East, Site West).